Wednesday 6th September 2017

Pro Production Environments Transactional emails being tagged as spam

We've identified a problem with email deliverability of all transactional emails being sent from production environments. All such emails are being treated as spam. We believe this is in relation to our recent transition from AWS SES to Sendgrid. Our infrastructure team is working on an incident report and steps to rectify this situation and we'll be posting updates as soon as possible.

Update (9/6 1:15 PST) Due to the suspension of the underlying AWS SES account, we migrated our email service to Sendgrid on Sep 5th. Due to this change, emails could be going to your users’ spam folders. In order to prevent that from happening in future, we need you to transition your current Amazon SES verification records to new Sendgrid based records as soon as possible. This needs to be done for each email domain used for your Magento Cloud stores. Our support team will be getting in touch with you about the exact changes through the ticketing system in the next hour.

Update (9/6 10am PST): Our infra team will be reaching out in the next couple of hours, via the ticketing system, to all affected customers with the updated DNS changes that customers will need to make on their end to rectify this issue. If your site is affected, you can also file an urgent ticket and list out the email domains in that ticket to get this process started. Incident report will be provided before the end of the day (pacific time).