Wednesday 30th May 2018

US PaaS Partial Outage on us.magento.cloud

Update 31/05/2018 07:03 UTC

Normal service has been restored to the orchestration system and customers can deploy as normal. We will continue to monitor to ensure it remains operational.

Update 31/05/2018 06:45 UTC

We have restored the orchestration system and are investigating environments that have frozen builds. Please create a support ticket at (https://accounts.magento.cloud/support) if your deployment has stuck.


We have identified an issue with the orchestration system for the us.magento.cloud region. Customers cannot currently push code. We expect no downtime for live sites.

Action is currently underway to repair the issue.